<!doctype html >
<!--[if IE 8]>
<html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>
<html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!-->
<html lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
<title>Rest in peace legend! Reggae music great Apple Gabriel passes on</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta name="msvalidate.01" content="7A89BBCAE6ACD204B4B13E1B40EBBA43" />
<meta name="google-site-verification" content="MUkcO3O6qR9oZApIzHt9XYCZ81zZEQrN3Uk5yXlw5Ew" />
<script src="/cdn-cgi/apps/head/rvWAhSrdF7q5d7KE17CuTqVZ7XI.js"></script><link rel="pingback" href="" />
<meta http-equiv="x-dns-prefetch-control" content="on">
<link rel="dns-prefetch" href="//www.googletagmanager.com/" />
<link rel="dns-prefetch" href="//www.googletagservices.com/" />
<link rel="dns-prefetch" href="//fonts.googleapis.com" />
<link rel="dns-prefetch" href="//fonts.gstatic.com" />
<link rel="dns-prefetch" href="//0.gravatar.com/" />
<link rel="dns-prefetch" href="//2.gravatar.com/" />
<link rel="dns-prefetch" href="//1.gravatar.com/" />
<link rel="dns-prefetch" href="//api.traq.li/" />
<link rel="dns-prefetch" href="//js-agent.newrelic.com/" />
<link rel="dns-prefetch" href="//www.youtube.com/" /><meta property="og:image" content="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/EUBkkhTXgAMnqcx.jpeg" /><meta name="author" content="Grace Kerongo">
<link rel="icon" type="image/png" href="https://media.mpasho.co.ke/wp-content/uploads/templateassets/logo_favicon.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://cdn.mpasho.co.ke/wp-content/uploads/templateassets/logo_iphone_76x76px.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://media.mpasho.co.ke/wp-content/uploads/templateassets/logo_iphone_120x120px.png" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://media.mpasho.co.ke/wp-content/uploads/templateassets/logo_iphone_144x144px.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://media.mpasho.co.ke/wp-content/uploads/templateassets/logo_iphone_114x114px.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://media.mpasho.co.ke/wp-content/uploads/templateassets/logo_iphone_144x144px.png" />

<meta name="description" content="Reggae has been stopped, temporarily by the sudden death of Jamaican legend Apple Gabriel." />
<link rel="canonical" href="https://mpasho.co.ke/rest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on/" />
<link rel="publisher" href="https://google.com/+MpashoNews" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Rest in peace legend! Reggae music great Apple Gabriel passes on" />
<meta property="og:description" content="Reggae has been stopped, temporarily by the sudden death of Jamaican legend Apple Gabriel." />
<meta property="og:url" content="https://mpasho.co.ke/rest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on/" />
<meta property="og:site_name" content="Mpasho News" />
<meta property="article:publisher" content="https://www.facebook.com/mpashonews" />
<meta property="article:tag" content="Apple Gabriel" />
<meta property="article:section" content="Entertainment" />
<meta property="article:published_time" content="2020-03-27T08:00:53+00:00" />
<meta property="fb:app_id" content="529729487155241" />
<meta property="og:image" content="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/EUBkkhTXgAMnqcx.jpeg" />
<meta property="og:image:secure_url" content="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/EUBkkhTXgAMnqcx.jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Reggae has been stopped, temporarily by the sudden death of Jamaican legend Apple Gabriel." />
<meta name="twitter:title" content="Rest in peace legend! Reggae music great Apple Gabriel passes on" />
<meta name="twitter:site" content="@MpashoNews" />
<meta name="twitter:image" content="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/EUBkkhTXgAMnqcx.jpeg" />
<meta name="twitter:creator" content="@MpashoNews" />

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mpasho.co.ke\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.8.12' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css' href='https://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.8.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://mpasho.co.ke/wp-content/themes/Newspaper/style.css' type='text/css' media='all' />
<script type='text/javascript' src='https://mpasho.co.ke/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://mpasho.co.ke/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='https://api.w.org/' href='https://mpasho.co.ke/wp-json/' />
<link rel='shortlink' href='https://mpasho.co.ke/?p=359209' />
<link rel="alternate" type="application/json+oembed" href="https://mpasho.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmpasho.co.ke%2Frest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mpasho.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmpasho.co.ke%2Frest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on%2F&#038;format=xml" />
<meta property="fb:pages" content="955751467785034" />
<meta property="ia:markup_url" content="https://mpasho.co.ke/rest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on/?ia_markup=1" />
<link rel="amphtml" href="https://mpasho.co.ke/rest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on/?amp_markup=1">
<!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->

<meta name="theme-color" content="#ef4823">

<meta name="msapplication-navbutton-color" content="#ef4823">

<meta name="apple-mobile-web-app-status-bar-style" content="black"><!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://mpasho.co.ke/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://mpasho.co.ke/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><link rel="amphtml" href="https://mpasho.co.ke/rest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on/amp/">

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="https:\/\/mpasho.co.ke\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.4";
var td_get_template_directory_uri="https:\/\/mpasho.co.ke\/wp-content\/themes\/Newspaper";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="show";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="show";
var tds_more_articles_on_post_time_to_wait="1";
var tds_more_articles_on_post_pages_distance_from_top=2500;
var tds_theme_color_site_wide="#ef4823";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="_blank";
</script>

<style>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</style>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-54491804-1', 'auto', {'useAmpClientId': true});
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script> <style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/


li.menu-item.menu-item-type-custom.menu-item-object-custom.td-menu-item.td-normal-menu.menu-item-329298 {
    background: red;
}

li.menu-item.menu-item-type-custom.menu-item-object-custom.td-menu-item.td-normal-menu.menu-item-329298:hover {
    background-color: orange !important;
}		</style>
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5TDQKM');</script>


<script type='text/javascript'>var _sf_startpt = (new Date()).getTime()</script>
<style id='chartbeat-flicker-control-style' type='text/css'>body {
        visibility: hidden !important;
    }</style>
<script type="text/javascript">
        var _sf_async_config = _sf_async_config || {};
        _sf_async_config.uid = 64340;
        _sf_async_config.domain = 'mpasho.co.ke';
        _sf_async_config.useCanonical = true;
        var _sf_startpt = (new Date()).getTime();
        window.setTimeout(function () {
            var hider = document.getElementById('chartbeat-flicker-control-style');
            if (hider) {
                hider.parentNode.removeChild(hider);
            }
        }, 1000);
    </script>
<script src="//static.chartbeat.com/js/chartbeat_mab.js" async></script>
<script type='text/javascript' src='//www.youtube.com/iframe_api' async></script>


<script async src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>
<script>
googletag.cmd.push(function() {

  // This mapping will only display ads when user is on mobile or tablet sized viewport
var mapping3 = googletag.sizeMapping().
  addSize([0, 0], []).
  addSize([1050, 200], [728, 90]). // Desktop
  addSize([320, 700], [300, 250]). // Tablet
  addSize([320, 400], [[320, 50], [320, 100],[300, 250],[300, 50]]). // mobile
  build();
 
   // This mapping will only display ads when user is on mobile or tablet sized viewport
var mapping4 = googletag.sizeMapping().
  addSize([0, 0], []).
  addSize([1050, 200], [970, 250]). // Desktop
  addSize([320, 700], [320, 100]). // Tablet
  addSize([320, 400], [320, 100]). // mobile
  build();

     // This mapping will only display ads when user is on mobile or tablet sized viewport
var mapping5 = googletag.sizeMapping().
  addSize([0, 0], []).
  addSize([1050, 200], [728, 90]). // Desktop
  addSize([320, 700], [[320, 120], [300, 250]]). // Tablet
  addSize([320, 400], [[320, 120], [300, 250]]). // mobile
  build();

  

    googletag.defineSlot('/18440288/MPASHO_homepage_runawayad_slot1', [[300, 250], [728, 90], [320, 100]], 'div-gpt-ad-1521798822133-0')
      .defineSizeMapping(mapping3)
      .setCollapseEmptyDiv(true)
      .addService(googletag.pubads());
    googletag.defineSlot('/18440288/MPASHO_homepage_runawayad_slot2', [[320, 100], [970, 250]], 'div-gpt-ad-1521798822133-1')
      .defineSizeMapping(mapping4)
      .setCollapseEmptyDiv(true)
      .addService(googletag.pubads());
    googletag.defineSlot('/18440288/MPASHO_Homepage_Slot3', [[320, 100], [300, 250], [728, 90]], 'div-gpt-ad-1526275978385-0')
      .defineSizeMapping(mapping5)
      .setCollapseEmptyDiv(true)
      .addService(googletag.pubads());
    googletag.defineSlot('/18440288/mpasho_interstitial', [1, 1], 'div-gpt-ad-1560261179134-0')
      .addService(googletag.pubads());
        googletag.defineSlot('/18440288/MPASHO_sidebar_adunit_slot1', [300, 600], 'div-gpt-ad-1574225080085-0').addService(googletag.pubads());

    googletag.defineSlot('/18440288/MPASHO_sidebar_adunit_slot2', [300, 250], 'div-gpt-ad-1560413099409-0')
      .addService(googletag.pubads());
    googletag.defineSlot('/18440288/MPASHO_sidebar_adunit_slot3', [300, 250], 'div-gpt-ad-1560413140164-0')
      .addService(googletag.pubads());
    googletag.defineSlot('/18440288/MPASHO_inarticle_leaderboard_1', [300, 250], 'div-gpt-ad-1560413440032-0')
      .addService(googletag.pubads());
   
    googletag.pubads().enableSingleRequest();
    googletag.pubads().enableVideoAds();    
    googletag.enableServices();
  });

</script>


<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/radioafricagroup-mpasho/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>

<script charset="UTF-8" src="//cdn.sendpulse.com/js/push/90d9ba6c113781e34592b48b91adf909_1.js" async></script>
<script data-ad-client="ca-pub-6073518695523995" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
</head>
<body class="post-template-default single single-post postid-359209 single-format-standard rest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on single_template_2 wpb-js-composer js-comp-ver-4.12.1 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<script async src="//get.optad360.io/sf/a7d58bad-9b18-4b56-8050-54010f7490b3/plugin.min.js"></script>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5TDQKM"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>


<div id='div-gpt-ad-1558428752960-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1558428752960-0'); });
</script>
</div>
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/mpashonews" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://instagram.com/mpashogram" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://soundcloud.com/mpasho-news" title="Soundcloud">
<i class="td-icon-font td-icon-soundcloud"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://mpashonews.tumblr.com/" title="Tumblr">
<i class="td-icon-font td-icon-tumblr"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/MpashoNews" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/channel/UCW32HFDtaC_PVhsehviEq0w" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-td-header-container"><ul id="menu-td-header" class="td-mobile-main-menu"><li id="menu-item-256829" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first menu-item-256829"><a href="https://mpasho.co.ke/category/latest/">Latest</a></li>
<li id="menu-item-55092" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-55092"><a title="Mpasho Exclusives" href="https://mpasho.co.ke/category/exclusives/">Exclusives<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><a href="https://mpasho.co.ke/category/exclusives/mpashoinvestigates/">Mpasho Investigates</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/exclusives/wembe/">Wembe</a></li>
</ul>
</li>
<li id="menu-item-71970" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-71970"><a title="Entertainment News" href="https://mpasho.co.ke/category/entertainment/">Entertainment<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/entertainment/events/">Events</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/entertainment/music/">Music &amp; Radio</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/entertainment/photos/">Photos</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/entertainment/tv/">TV and Movies</a></li>
</ul>
</li>
<li id="menu-item-283539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-283539"><a href="https://mpasho.co.ke/category/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-215819" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-215819"><a href="https://mpasho.co.ke/category/kenya_decides/">Kenya Decides</a></li>
<li id="menu-item-7595" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-7595"><a href="https://mpasho.co.ke/politics/">Politics<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/politics/obama/">Obama In Kenya</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-75854" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75854"><a href="https://mpasho.co.ke/category/videos/">Mpasho Tv</a></li>
<li id="menu-item-164092" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-has-children menu-item-164092"><a href="https://mpasho.co.ke/category/lifestyle/">Lifestyle<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/cars/">Cars</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/crime/">Crime</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/death/">Death</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/education/">Education</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/fashion/">Fashion</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/health/">Health</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/history/">History</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/posh-living/">Posh Living</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/relationship-issues/">Relationship Issues</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/road-accidents/">Road Accidents</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/slay-queen/">Slay Queen</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/socialites/">Socialites</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/terrorism/">Terrorism</a></li>
<li class="menu-item-0"><a href="https://mpasho.co.ke/category/lifestyle/popeinkenya/">The Pope In Kenya</a></li>
<li id="menu-item-155947" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-155947"><a href="https://mpasho.co.ke/category/eventnews/">Events</a></li>
</ul>
</li>
</ul></div> </div>
</div>

</div><div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://mpasho.co.ke/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap">

<div class="td-header-wrap td-header-style-3">
<div class="td-header-top-menu-full">
<div class="td-container td-header-row td-header-top-menu">

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<div class="td-login-wrap">
<a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full">
<div class="td-container td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://mpasho.co.ke/">
<img class="td-retina-data" data-retina="https://media.mpasho.co.ke/wp-content/uploads/templateassets/logo_main_300x100px.png" src="https://media.mpasho.co.ke/wp-content/uploads/templateassets/logo_main_300x100px.png" alt="Mpasho News" title="Mpasho Entertainment News" />
<span class="td-visual-hidden">Mpasho News</span>
</a>
</div>
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">
<div class="td-a-rec td-a-rec-id-header  "> 
<div id='div-gpt-ad-1521798822133-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1521798822133-0'); });
</script>
</div>
</div>
</div> </div>
</div>
</div>
<div class="td-header-menu-wrap-full">
<div class="td-header-menu-wrap">
<div class="td-container td-header-row td-header-main-menu black-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-mobile" href="https://mpasho.co.ke/">
<img class="td-retina-data" data-retina="https://cdn.mpasho.co.ke/wp-content/uploads/2015/06/logowhite.png" src="https://cdn.mpasho.co.ke/wp-content/uploads/2015/06/logowhite.png" alt="Mpasho News" title="Mpasho Entertainment News" />
</a>
<a class="td-header-logo td-sticky-mobile" href="https://mpasho.co.ke/">
<img class="td-retina-data" data-retina="https://media.mpasho.co.ke/wp-content/uploads/templateassets/logo_main_300x100px.png" src="https://media.mpasho.co.ke/wp-content/uploads/templateassets/logo_main_300x100px.png" alt="Mpasho News" title="Mpasho Entertainment News" />
</a>
</div>
<div class="menu-td-header-container"><ul id="menu-td-header-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-normal-menu menu-item-256829"><a href="https://mpasho.co.ke/category/latest/">Latest</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-55092"><a title="Mpasho Exclusives" href="https://mpasho.co.ke/category/exclusives/">Exclusives</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5e7db74a3e6c7_rand td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_2_5e7db74a3e6c7"><script>var block_td_uid_2_5e7db74a3e6c7 = new tdBlock();
block_td_uid_2_5e7db74a3e6c7.id = "td_uid_2_5e7db74a3e6c7";
block_td_uid_2_5e7db74a3e6c7.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2597","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5e7db74a3e6c7_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5e7db74a3e6c7.td_column_number = "3";
block_td_uid_2_5e7db74a3e6c7.block_type = "td_block_mega_menu";
block_td_uid_2_5e7db74a3e6c7.post_count = "4";
block_td_uid_2_5e7db74a3e6c7.found_posts = "2076";
block_td_uid_2_5e7db74a3e6c7.header_color = "";
block_td_uid_2_5e7db74a3e6c7.ajax_pagination_infinite_stop = "";
block_td_uid_2_5e7db74a3e6c7.max_num_pages = "519";
tdBlocksArray.push(block_td_uid_2_5e7db74a3e6c7);
</script> <script>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</script>
<div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_2_5e7db74a3e6c7" id="td_uid_3_5e7db74a40110" data-td_block_id="td_uid_2_5e7db74a3e6c7" data-td_filter_value="" href="https://mpasho.co.ke/category/exclusives/">All</a><a class="mega-menu-sub-cat-td_uid_2_5e7db74a3e6c7" id="td_uid_4_5e7db74a40217" data-td_block_id="td_uid_2_5e7db74a3e6c7" data-td_filter_value="2598" href="https://mpasho.co.ke/category/exclusives/mpashoinvestigates/">Mpasho Investigates</a><a class="mega-menu-sub-cat-td_uid_2_5e7db74a3e6c7" id="td_uid_5_5e7db74a4031d" data-td_block_id="td_uid_2_5e7db74a3e6c7" data-td_filter_value="19" href="https://mpasho.co.ke/category/exclusives/wembe/">Wembe</a></div></div><div id=td_uid_2_5e7db74a3e6c7 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/mpasho-investigates-shimo-mbaya-ni-ya-nyoka-prostitute-confesses-mpasho/" rel="bookmark" title="&#8216;Shimo mbaya ni ya nyoka,&#8217; Kinoo Sex worker confesses to Mpasho"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2015/12/imageedit_1_4694144144-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2015/12/imageedit_1_4694144144-218x150.jpg 218w, https://media.mpasho.co.ke/wp-content/uploads/2015/12/imageedit_1_4694144144-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="prostitutes in kenya" title="&#8216;Shimo mbaya ni ya nyoka,&#8217; Kinoo Sex worker confesses to Mpasho" /></a></div> <a href="https://mpasho.co.ke/category/latest/" class="td-post-category">Latest News</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/mpasho-investigates-shimo-mbaya-ni-ya-nyoka-prostitute-confesses-mpasho/" rel="bookmark" title="&#8216;Shimo mbaya ni ya nyoka,&#8217; Kinoo Sex worker confesses to Mpasho">&#8216;Shimo mbaya ni ya nyoka,&#8217; Kinoo Sex worker confesses to Mpasho</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/mpasho-investigates-part-3-nafanya-umalaya-juu-sina-pesa-ya-kuanza-biashara-prositute-confesses-to-mpasho-audio-evidence/" rel="bookmark" title="&#8216;Why i became a sex worker!&#8217; Prositute confesses to Mpasho"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2016/08/prostitution-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2016/08/prostitution-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2016/08/prostitution-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Koinange prostitute" title="&#8216;Why i became a sex worker!&#8217; Prositute confesses to Mpasho" /></a></div> <a href="https://mpasho.co.ke/category/latest/" class="td-post-category">Latest News</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/mpasho-investigates-part-3-nafanya-umalaya-juu-sina-pesa-ya-kuanza-biashara-prositute-confesses-to-mpasho-audio-evidence/" rel="bookmark" title="&#8216;Why i became a sex worker!&#8217; Prositute confesses to Mpasho">&#8216;Why i became a sex worker!&#8217; Prositute confesses to Mpasho</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/5-of-the-silliest-reasons-kenyan-women-give-for-cheating/" rel="bookmark" title="5 Of The Silliest Reasons Kenyan Women Give For Cheating"><img width="218" height="150" class="entry-thumb" src="https://media.mpasho.co.ke/wp-content/uploads/2015/11/Kenyan-Women-beads-218x150.jpg" srcset="https://media.mpasho.co.ke/wp-content/uploads/2015/11/Kenyan-Women-beads-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2015/11/Kenyan-Women-beads-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Kenyan Women Beads" title="5 Of The Silliest Reasons Kenyan Women Give For Cheating" /></a></div> <a href="https://mpasho.co.ke/category/exclusives/" class="td-post-category">Exclusives</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/5-of-the-silliest-reasons-kenyan-women-give-for-cheating/" rel="bookmark" title="5 Of The Silliest Reasons Kenyan Women Give For Cheating">5 Of The Silliest Reasons Kenyan Women Give For Cheating</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/guardian-angel-narrates-how-he-was-almost-poisoned-by-a-good-samaritan/" rel="bookmark" title="Guardian Angel narrates how step mother almost poisoned him"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2018/06/g-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2018/06/g-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2018/06/g-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Guardian Angel" title="Guardian Angel narrates how step mother almost poisoned him" /></a></div> <a href="https://mpasho.co.ke/category/lifestyle/crime/" class="td-post-category">Crime</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/guardian-angel-narrates-how-he-was-almost-poisoned-by-a-good-samaritan/" rel="bookmark" title="Guardian Angel narrates how step mother almost poisoned him">Guardian Angel narrates how step mother almost poisoned him</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5e7db74a3e6c7" data-td_block_id="td_uid_2_5e7db74a3e6c7"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_2_5e7db74a3e6c7" data-td_block_id="td_uid_2_5e7db74a3e6c7"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-71970"><a title="Entertainment News" href="https://mpasho.co.ke/category/entertainment/">Entertainment</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_6_5e7db74a4b695_rand td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_6_5e7db74a4b695"><script>var block_td_uid_6_5e7db74a4b695 = new tdBlock();
block_td_uid_6_5e7db74a4b695.id = "td_uid_6_5e7db74a4b695";
block_td_uid_6_5e7db74a4b695.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"3523","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_6_5e7db74a4b695_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_6_5e7db74a4b695.td_column_number = "3";
block_td_uid_6_5e7db74a4b695.block_type = "td_block_mega_menu";
block_td_uid_6_5e7db74a4b695.post_count = "4";
block_td_uid_6_5e7db74a4b695.found_posts = "21600";
block_td_uid_6_5e7db74a4b695.header_color = "";
block_td_uid_6_5e7db74a4b695.ajax_pagination_infinite_stop = "";
block_td_uid_6_5e7db74a4b695.max_num_pages = "5400";
tdBlocksArray.push(block_td_uid_6_5e7db74a4b695);
</script> <script>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</script>
<div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_6_5e7db74a4b695" id="td_uid_7_5e7db74b54643" data-td_block_id="td_uid_6_5e7db74a4b695" data-td_filter_value="" href="https://mpasho.co.ke/category/entertainment/">All</a><a class="mega-menu-sub-cat-td_uid_6_5e7db74a4b695" id="td_uid_8_5e7db74b5473c" data-td_block_id="td_uid_6_5e7db74a4b695" data-td_filter_value="9" href="https://mpasho.co.ke/category/entertainment/events/">Events</a><a class="mega-menu-sub-cat-td_uid_6_5e7db74a4b695" id="td_uid_9_5e7db74b54844" data-td_block_id="td_uid_6_5e7db74a4b695" data-td_filter_value="5" href="https://mpasho.co.ke/category/entertainment/music/">Music &amp; Radio</a><a class="mega-menu-sub-cat-td_uid_6_5e7db74a4b695" id="td_uid_10_5e7db74b5493d" data-td_block_id="td_uid_6_5e7db74a4b695" data-td_filter_value="3524" href="https://mpasho.co.ke/category/entertainment/photos/">Photos</a><a class="mega-menu-sub-cat-td_uid_6_5e7db74a4b695" id="td_uid_11_5e7db74b54a37" data-td_block_id="td_uid_6_5e7db74a4b695" data-td_filter_value="2" href="https://mpasho.co.ke/category/entertainment/tv/">TV and Movies</a></div></div><div id=td_uid_6_5e7db74a4b695 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/quarantine-fans-question-corazon-kwamboka-maureen-waititus-ex-frankie/" rel="bookmark" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie"><img width="218" height="146" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2016/06/Frankie-Trainer2.jpg" alt="" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/quarantine-fans-question-corazon-kwamboka-maureen-waititus-ex-frankie/" rel="bookmark" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie">&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/house-arrest-read-zari-hassans-letter-estate-management/" rel="bookmark" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Zari-Hassan-666-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Zari-Hassan-666-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Zari-Hassan-666-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Zari Hassan" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/house-arrest-read-zari-hassans-letter-estate-management/" rel="bookmark" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management">&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/rough-rude-kate-actress-reveals-reasons-snob-fans/" rel="bookmark" title="Some are rough and rude! Kate actress reveals the reasons for being a snob to her fans"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/catt-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/catt-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/catt-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Some are rough and rude! Kate actress reveals the reasons for being a snob to her fans" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/rough-rude-kate-actress-reveals-reasons-snob-fans/" rel="bookmark" title="Some are rough and rude! Kate actress reveals the reasons for being a snob to her fans">Some are rough and rude! Kate actress reveals the reasons for&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/i-chipod-her-jowie-leaves-fans-in-stitches-after-scare/" rel="bookmark" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/JOWIE-JOWI-88-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/JOWIE-JOWI-88-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/JOWIE-JOWI-88-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Jowie Joe" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/i-chipod-her-jowie-leaves-fans-in-stitches-after-scare/" rel="bookmark" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;">&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_6_5e7db74a4b695" data-td_block_id="td_uid_6_5e7db74a4b695"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_6_5e7db74a4b695" data-td_block_id="td_uid_6_5e7db74a4b695"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-283539"><a href="https://mpasho.co.ke/category/opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-215819"><a href="https://mpasho.co.ke/category/kenya_decides/">Kenya Decides</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-mega-menu menu-item-7595"><a href="https://mpasho.co.ke/politics/">Politics</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_12_5e7db74b644c3_rand td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_12_5e7db74b644c3"><script>var block_td_uid_12_5e7db74b644c3 = new tdBlock();
block_td_uid_12_5e7db74b644c3.id = "td_uid_12_5e7db74b644c3";
block_td_uid_12_5e7db74b644c3.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"520","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_12_5e7db74b644c3_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_12_5e7db74b644c3.td_column_number = "3";
block_td_uid_12_5e7db74b644c3.block_type = "td_block_mega_menu";
block_td_uid_12_5e7db74b644c3.post_count = "4";
block_td_uid_12_5e7db74b644c3.found_posts = "2276";
block_td_uid_12_5e7db74b644c3.header_color = "";
block_td_uid_12_5e7db74b644c3.ajax_pagination_infinite_stop = "";
block_td_uid_12_5e7db74b644c3.max_num_pages = "569";
tdBlocksArray.push(block_td_uid_12_5e7db74b644c3);
</script> <script>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</script>
<div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_12_5e7db74b644c3" id="td_uid_13_5e7db74b66fb9" data-td_block_id="td_uid_12_5e7db74b644c3" data-td_filter_value="" href="https://mpasho.co.ke/category/politics/">All</a><a class="mega-menu-sub-cat-td_uid_12_5e7db74b644c3" id="td_uid_14_5e7db74b67098" data-td_block_id="td_uid_12_5e7db74b644c3" data-td_filter_value="3945" href="https://mpasho.co.ke/category/politics/obama/">Obama In Kenya</a></div></div><div id=td_uid_12_5e7db74b644c3 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/covid-19-patient-at-mbagathi-speaks-out-on-conditions-in-quarantine/" rel="bookmark" title="COVID-19 patient at Mbagathi speaks out on conditions in quarantine"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/images-1-218x150.jpeg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/images-1-218x150.jpeg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/images-1-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="COVID-19 patient at Mbagathi speaks out on conditions in quarantine" /></a></div> <a href="https://mpasho.co.ke/category/latest/" class="td-post-category">Latest News</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/covid-19-patient-at-mbagathi-speaks-out-on-conditions-in-quarantine/" rel="bookmark" title="COVID-19 patient at Mbagathi speaks out on conditions in quarantine">COVID-19 patient at Mbagathi speaks out on conditions in quarantine</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/leaked-love-texts-between-governor-lonyangapuo-and-lover/" rel="bookmark" title="Leaked! Love texts between Governor Lonyangapuo and lover"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/images-2-218x150.jpeg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/images-2-218x150.jpeg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/images-2-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Leaked! Love texts between Governor Lonyangapuo and lover" /></a></div> <a href="https://mpasho.co.ke/category/latest/" class="td-post-category">Latest News</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/leaked-love-texts-between-governor-lonyangapuo-and-lover/" rel="bookmark" title="Leaked! Love texts between Governor Lonyangapuo and lover">Leaked! Love texts between Governor Lonyangapuo and lover</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/this-is-why-mike-sonkos-post-on-bill-gates-has-gone-viral/" rel="bookmark" title="This is why Mike Sonko&#8217;s post on Bill Gates has gone viral"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2019/12/WhatsApp-Image-2019-12-06-at-13.00.29-218x150.jpeg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2019/12/WhatsApp-Image-2019-12-06-at-13.00.29-218x150.jpeg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2019/12/WhatsApp-Image-2019-12-06-at-13.00.29-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="This is why Mike Sonko&#8217;s post on Bill Gates has gone viral" /></a></div> <a href="https://mpasho.co.ke/category/latest/" class="td-post-category">Latest News</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/this-is-why-mike-sonkos-post-on-bill-gates-has-gone-viral/" rel="bookmark" title="This is why Mike Sonko&#8217;s post on Bill Gates has gone viral">This is why Mike Sonko&#8217;s post on Bill Gates has gone&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/fan-asks-how-is-the-man-you-tried-to-kill-babu-owino-responds/" rel="bookmark" title="Fan asks, &#8216;How is the man you tried to kill?&#8217; Babu Owino responds"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/01/WhatsApp-Image-2020-01-20-at-12.19.36-1-218x150.jpeg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/01/WhatsApp-Image-2020-01-20-at-12.19.36-1-218x150.jpeg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/01/WhatsApp-Image-2020-01-20-at-12.19.36-1-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Babu Owino in court. Photo/ Enost Teche" title="Fan asks, &#8216;How is the man you tried to kill?&#8217; Babu Owino responds" /></a></div> <a href="https://mpasho.co.ke/category/latest/" class="td-post-category">Latest News</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/fan-asks-how-is-the-man-you-tried-to-kill-babu-owino-responds/" rel="bookmark" title="Fan asks, &#8216;How is the man you tried to kill?&#8217; Babu Owino responds">Fan asks, &#8216;How is the man you tried to kill?&#8217; Babu&#8230;</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_12_5e7db74b644c3" data-td_block_id="td_uid_12_5e7db74b644c3"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_12_5e7db74b644c3" data-td_block_id="td_uid_12_5e7db74b644c3"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-75854"><a href="https://mpasho.co.ke/category/videos/">Mpasho Tv</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_15_5e7db74b6f3c2_rand td-no-subcats td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_15_5e7db74b6f3c2"><script>var block_td_uid_15_5e7db74b6f3c2 = new tdBlock();
block_td_uid_15_5e7db74b6f3c2.id = "td_uid_15_5e7db74b6f3c2";
block_td_uid_15_5e7db74b6f3c2.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_5e7db74b6f3c2_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_15_5e7db74b6f3c2.td_column_number = "3";
block_td_uid_15_5e7db74b6f3c2.block_type = "td_block_mega_menu";
block_td_uid_15_5e7db74b6f3c2.post_count = "5";
block_td_uid_15_5e7db74b6f3c2.found_posts = "3357";
block_td_uid_15_5e7db74b6f3c2.header_color = "";
block_td_uid_15_5e7db74b6f3c2.ajax_pagination_infinite_stop = "";
block_td_uid_15_5e7db74b6f3c2.max_num_pages = "672";
tdBlocksArray.push(block_td_uid_15_5e7db74b6f3c2);
</script><div id=td_uid_15_5e7db74b6f3c2 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/quarantine-fans-question-corazon-kwamboka-maureen-waititus-ex-frankie/" rel="bookmark" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie"><img width="218" height="146" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2016/06/Frankie-Trainer2.jpg" alt="" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/quarantine-fans-question-corazon-kwamboka-maureen-waititus-ex-frankie/" rel="bookmark" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie">&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/house-arrest-read-zari-hassans-letter-estate-management/" rel="bookmark" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Zari-Hassan-666-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Zari-Hassan-666-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Zari-Hassan-666-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Zari Hassan" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/house-arrest-read-zari-hassans-letter-estate-management/" rel="bookmark" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management">&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/i-chipod-her-jowie-leaves-fans-in-stitches-after-scare/" rel="bookmark" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/JOWIE-JOWI-88-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/JOWIE-JOWI-88-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/JOWIE-JOWI-88-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Jowie Joe" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/i-chipod-her-jowie-leaves-fans-in-stitches-after-scare/" rel="bookmark" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;">&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/atatoklezea-tu-j-blessings-ex-chantelle-search-soulmate/" rel="bookmark" title="Atatoklezea tu! J Blessing&#8217;s ex Chantelle in search of her soulmate"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/unnamed-file-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/unnamed-file-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/unnamed-file-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Atatoklezea tu! J Blessing&#8217;s ex Chantelle in search of her soulmate" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/atatoklezea-tu-j-blessings-ex-chantelle-search-soulmate/" rel="bookmark" title="Atatoklezea tu! J Blessing&#8217;s ex Chantelle in search of her soulmate">Atatoklezea tu! J Blessing&#8217;s ex Chantelle in search of her soulmate</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/bro-if-she-says-hes-just-a-friend-zaris-son-raphael-shares-love-advice/" rel="bookmark" title="&#8216;Bro, if she says he&#8217;s just a friend&#8230;&#8217; Zari&#8217;s son Raphael shares love advice"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/raphael-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/raphael-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/raphael-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="&#8216;Bro, if she says he&#8217;s just a friend&#8230;&#8217; Zari&#8217;s son Raphael shares love advice" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/bro-if-she-says-hes-just-a-friend-zaris-son-raphael-shares-love-advice/" rel="bookmark" title="&#8216;Bro, if she says he&#8217;s just a friend&#8230;&#8217; Zari&#8217;s son Raphael shares love advice">&#8216;Bro, if she says he&#8217;s just a friend&#8230;&#8217; Zari&#8217;s son Raphael&#8230;</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_5e7db74b6f3c2" data-td_block_id="td_uid_15_5e7db74b6f3c2"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_15_5e7db74b6f3c2" data-td_block_id="td_uid_15_5e7db74b6f3c2"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-mega-menu menu-item-164092"><a href="https://mpasho.co.ke/category/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_16_5e7db74b72bd4_rand td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_16_5e7db74b72bd4"><script>var block_td_uid_16_5e7db74b72bd4 = new tdBlock();
block_td_uid_16_5e7db74b72bd4.id = "td_uid_16_5e7db74b72bd4";
block_td_uid_16_5e7db74b72bd4.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"7","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_16_5e7db74b72bd4_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_16_5e7db74b72bd4.td_column_number = "3";
block_td_uid_16_5e7db74b72bd4.block_type = "td_block_mega_menu";
block_td_uid_16_5e7db74b72bd4.post_count = "4";
block_td_uid_16_5e7db74b72bd4.found_posts = "22139";
block_td_uid_16_5e7db74b72bd4.header_color = "";
block_td_uid_16_5e7db74b72bd4.ajax_pagination_infinite_stop = "";
block_td_uid_16_5e7db74b72bd4.max_num_pages = "5535";
tdBlocksArray.push(block_td_uid_16_5e7db74b72bd4);
</script> <script>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</script>
<div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_17_5e7db74b742f9" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="" href="https://mpasho.co.ke/category/lifestyle/">All</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_18_5e7db74b743da" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="14105" href="https://mpasho.co.ke/category/lifestyle/cars/">Cars</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_19_5e7db74b744b5" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="7245" href="https://mpasho.co.ke/category/lifestyle/crime/">Crime</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_20_5e7db74b7458a" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="8189" href="https://mpasho.co.ke/category/lifestyle/death/">Death</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_21_5e7db74b74660" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="12695" href="https://mpasho.co.ke/category/lifestyle/education/">Education</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_22_5e7db74b7473d" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="6" href="https://mpasho.co.ke/category/lifestyle/fashion/">Fashion</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_23_5e7db74b74812" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="7257" href="https://mpasho.co.ke/category/lifestyle/health/">Health</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_24_5e7db74b748ea" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="14639" href="https://mpasho.co.ke/category/lifestyle/history/">History</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_25_5e7db74b749e0" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="14122" href="https://mpasho.co.ke/category/lifestyle/posh-living/">Posh Living</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_26_5e7db74b74abb" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="12045" href="https://mpasho.co.ke/category/lifestyle/relationship-issues/">Relationship Issues</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_27_5e7db74b74b9e" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="7321" href="https://mpasho.co.ke/category/lifestyle/road-accidents/">Road Accidents</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_28_5e7db74b74c9c" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="12044" href="https://mpasho.co.ke/category/lifestyle/slay-queen/">Slay Queen</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_29_5e7db74b74d7c" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="2556" href="https://mpasho.co.ke/category/lifestyle/socialites/">Socialites</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_30_5e7db74b74e62" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="15864" href="https://mpasho.co.ke/category/lifestyle/terrorism/">Terrorism</a><a class="mega-menu-sub-cat-td_uid_16_5e7db74b72bd4" id="td_uid_31_5e7db74b74f59" data-td_block_id="td_uid_16_5e7db74b72bd4" data-td_filter_value="5162" href="https://mpasho.co.ke/category/lifestyle/popeinkenya/">The Pope In Kenya</a></div></div><div id=td_uid_16_5e7db74b72bd4 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/quarantine-fans-question-corazon-kwamboka-maureen-waititus-ex-frankie/" rel="bookmark" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie"><img width="218" height="146" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2016/06/Frankie-Trainer2.jpg" alt="" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/quarantine-fans-question-corazon-kwamboka-maureen-waititus-ex-frankie/" rel="bookmark" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie">&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/house-arrest-read-zari-hassans-letter-estate-management/" rel="bookmark" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Zari-Hassan-666-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Zari-Hassan-666-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Zari-Hassan-666-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Zari Hassan" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/house-arrest-read-zari-hassans-letter-estate-management/" rel="bookmark" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management">&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/rough-rude-kate-actress-reveals-reasons-snob-fans/" rel="bookmark" title="Some are rough and rude! Kate actress reveals the reasons for being a snob to her fans"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/catt-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/catt-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/catt-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Some are rough and rude! Kate actress reveals the reasons for being a snob to her fans" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/rough-rude-kate-actress-reveals-reasons-snob-fans/" rel="bookmark" title="Some are rough and rude! Kate actress reveals the reasons for being a snob to her fans">Some are rough and rude! Kate actress reveals the reasons for&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/i-chipod-her-jowie-leaves-fans-in-stitches-after-scare/" rel="bookmark" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/JOWIE-JOWI-88-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/JOWIE-JOWI-88-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/JOWIE-JOWI-88-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Jowie Joe" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/i-chipod-her-jowie-leaves-fans-in-stitches-after-scare/" rel="bookmark" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;">&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_16_5e7db74b72bd4" data-td_block_id="td_uid_16_5e7db74b72bd4"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_16_5e7db74b72bd4" data-td_block_id="td_uid_16_5e7db74b72bd4"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-155947"><a href="https://mpasho.co.ke/category/eventnews/">Events</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_32_5e7db74bb03ae_rand td-no-subcats td_with_ajax_pagination td-pb-border-top" data-td-block-uid="td_uid_32_5e7db74bb03ae"><script>var block_td_uid_32_5e7db74bb03ae = new tdBlock();
block_td_uid_32_5e7db74bb03ae.id = "td_uid_32_5e7db74bb03ae";
block_td_uid_32_5e7db74bb03ae.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"1460","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_32_5e7db74bb03ae_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_32_5e7db74bb03ae.td_column_number = "3";
block_td_uid_32_5e7db74bb03ae.block_type = "td_block_mega_menu";
block_td_uid_32_5e7db74bb03ae.post_count = "5";
block_td_uid_32_5e7db74bb03ae.found_posts = "1477";
block_td_uid_32_5e7db74bb03ae.header_color = "";
block_td_uid_32_5e7db74bb03ae.ajax_pagination_infinite_stop = "";
block_td_uid_32_5e7db74bb03ae.max_num_pages = "296";
tdBlocksArray.push(block_td_uid_32_5e7db74bb03ae);
</script><div id=td_uid_32_5e7db74bb03ae class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/mambo-ni-digital-kenyans-are-now-forming-new-peculiar-habits/" rel="bookmark" title="Mambo ni digital! Kenyans are now forming new peculiar habits"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/ICEA_MotorInsurance-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/ICEA_MotorInsurance-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/ICEA_MotorInsurance-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="ICEA MotorInsurance" title="Mambo ni digital! Kenyans are now forming new peculiar habits" /></a></div> <a href="https://mpasho.co.ke/category/sponsored/" class="td-post-category">Sponsored</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/mambo-ni-digital-kenyans-are-now-forming-new-peculiar-habits/" rel="bookmark" title="Mambo ni digital! Kenyans are now forming new peculiar habits">Mambo ni digital! Kenyans are now forming new peculiar habits</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/laduuuuuma-watch-arsenal-vs-west-ham-united-live-on-showmax/" rel="bookmark" title="Laduuuuuma! Watch Arsenal vs West Ham United live on Showmax"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/ArsenalVSWestHam-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/ArsenalVSWestHam-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/ArsenalVSWestHam-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Laduuuuuma! Watch Arsenal vs West Ham United live on Showmax" /></a></div> <a href="https://mpasho.co.ke/category/sponsored/" class="td-post-category">Sponsored</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/laduuuuuma-watch-arsenal-vs-west-ham-united-live-on-showmax/" rel="bookmark" title="Laduuuuuma! Watch Arsenal vs West Ham United live on Showmax">Laduuuuuma! Watch Arsenal vs West Ham United live on Showmax</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/subscribe-today-showmax-special-offer-for-kenya-ending-soon/" rel="bookmark" title="Subscribe today! Showmax special offer for Kenya ending soon"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/02/AmbitionsOnShowmax_March2020-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/02/AmbitionsOnShowmax_March2020-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/02/AmbitionsOnShowmax_March2020-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Ambitions is now showing on Showmax" title="Subscribe today! Showmax special offer for Kenya ending soon" /></a></div> <a href="https://mpasho.co.ke/category/sponsored/" class="td-post-category">Sponsored</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/subscribe-today-showmax-special-offer-for-kenya-ending-soon/" rel="bookmark" title="Subscribe today! Showmax special offer for Kenya ending soon">Subscribe today! Showmax special offer for Kenya ending soon</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/username-investment-giving-free-land-needy-valentines/" rel="bookmark" title="Username Investment giving free land to the needy this Valentine&#8217;s"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/02/Kimani-Username-3-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/02/Kimani-Username-3-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/02/Kimani-Username-3-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Username Investment giving free land to the needy this Valentine&#8217;s" /></a></div> <a href="https://mpasho.co.ke/category/sponsored/" class="td-post-category">Sponsored</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/username-investment-giving-free-land-needy-valentines/" rel="bookmark" title="Username Investment giving free land to the needy this Valentine&#8217;s">Username Investment giving free land to the needy this Valentine&#8217;s</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/must-read-bro-code-reloaded-every-man-needs-know/" rel="bookmark" title="MUST READ: The Bro Code Reloaded &#8211; What every man needs to know!"><img width="218" height="150" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2017/03/Brocode1-218x150.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2017/03/Brocode1-218x150.jpg 218w, https://cdn.mpasho.co.ke/wp-content/uploads/2017/03/Brocode1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="MUST READ: The Bro Code Reloaded &#8211; What every man needs to know!" /></a></div> <a href="https://mpasho.co.ke/category/sponsored/" class="td-post-category">Sponsored</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/must-read-bro-code-reloaded-every-man-needs-know/" rel="bookmark" title="MUST READ: The Bro Code Reloaded &#8211; What every man needs to know!">MUST READ: The Bro Code Reloaded &#8211; What every man needs&#8230;</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_32_5e7db74bb03ae" data-td_block_id="td_uid_32_5e7db74bb03ae"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_32_5e7db74bb03ae" data-td_block_id="td_uid_32_5e7db74bb03ae"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
</ul>
</li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://mpasho.co.ke/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div> </div>
</div>
</div>
</div><div class="td-main-content-wrap">
<div class="td-container td-post-template-2">
<article id="post-359209" class="post-359209 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-latest tag-apple-gabriel" itemscope itemtype="https://schema.org/Article">
<div class="td-pb-row">
<div class="td-pb-span12">
<div class="td-post-header">
<div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="https://mpasho.co.ke/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Entertainment" class="entry-crumb" itemprop="url" href="https://mpasho.co.ke/category/entertainment/"><span itemprop="title">Entertainment</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content="Rest in peace legend! Reggae music great Apple Gabriel passes on"><meta itemprop="url" content="https://mpasho.co.ke/rest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on/">Rest in peace legend! Reggae music great Apple Gabriel passes on</span></div></div>
<ul class="td-category"><li class="entry-category"><a href="https://mpasho.co.ke/category/entertainment/">Entertainment</a></li><li class="entry-category"><a style="background-color:#7a4b00; color:#fff; border-color:#7a4b00;" href="https://mpasho.co.ke/category/latest/">Latest News</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">Rest in peace legend! Reggae music great Apple Gabriel passes on</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://mpasho.co.ke/author/grace-kerongo/">Grace Kerongo</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-27T08:00:53+00:00">March 27, 2020</time></span> </div>
</header>
</div>
</div>
</div> 
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-sharing td-post-sharing-top ">
<div class="td-default-sharing">
<a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fmpasho.co.ke%2Frest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a>
<a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Rest+in+peace+legend%21+Reggae+music+great+Apple+Gabriel+passes+on&url=https%3A%2F%2Fmpasho.co.ke%2Frest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on%2F&via=MpashoNews"><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a>
<a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://mpasho.co.ke/rest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
<a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://mpasho.co.ke/rest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on/&amp;media=https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/EUBkkhTXgAMnqcx.jpeg&description=Reggae has been stopped, temporarily by the sudden death of Jamaican legend Apple Gabriel." onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
<a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Rest+in+peace+legend%21+Reggae+music+great+Apple+Gabriel+passes+on%20-%20https%3A%2F%2Fmpasho.co.ke%2Frest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on%2F"><i class="td-icon-whatsapp"></i></a>
</div></div>
<div class="td-post-content">
<div class="td-post-featured-image"><img width="600" height="754" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/EUBkkhTXgAMnqcx.jpeg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/EUBkkhTXgAMnqcx.jpeg 600w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/EUBkkhTXgAMnqcx-199x250.jpeg 199w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/EUBkkhTXgAMnqcx-384x483.jpeg 384w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/EUBkkhTXgAMnqcx-334x420.jpeg 334w" sizes="(max-width: 600px) 100vw, 600px" alt="" title="EUBkkhTXgAMnqcx" /></div>
<div class="td-a-rec td-a-rec-id-content_top  ">
<div id='div-gpt-ad-1526275978385-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1526275978385-0'); });
</script>
</div></div><p>Reggae has been stopped, temporarily by the sudden death of Jamaican legend Apple Gabriel.</p>
<p>The star is said to have passed on yesterday. The details are scanty.</p>
<blockquote class="twitter-tweet" data-width="550">
<div class="td-a-rec td-a-rec-id-content_inlineright  ">
<div id='div-gpt-ad-1560413440032-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1560413440032-0'); });
</script>
</div>
<script src="//a.teads.tv/page/88366/tag" async="true"></script>
</div><p lang="en" dir="ltr">There is no end to a good thing. <a href="https://twitter.com/hashtag/RestInPeaceRasta?src=hash&amp;ref_src=twsrc%5Etfw">#RestInPeaceRasta</a> <a href="https://twitter.com/hashtag/AppleGabriel?src=hash&amp;ref_src=twsrc%5Etfw">#AppleGabriel</a> <a href="https://t.co/gob9LlmicY">pic.twitter.com/gob9LlmicY</a></p>
<p>&mdash; Salesman (@Samcom012) <a href="https://twitter.com/Samcom012/status/1243192933391699969?ref_src=twsrc%5Etfw">March 26, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<h3><a href="https://mpasho.co.ke/kenny-rogers-last-dying-thoughts-were-noble-photo/"><span style="color: #0000ff;">Kenny Rogers last dying thoughts were noble (Photo)</span></a></h3>
<p>However, his last Facebook post detailed a bitter star complaining about how he has been discharged from hospital and is now living in an old dilapidated car.</p>
<p><img class="aligncenter size-full wp-image-359239" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Screenshot_20200327-074843_Chrome-1.jpg" alt="" width="540" height="1170" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Screenshot_20200327-074843_Chrome-1.jpg 540w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Screenshot_20200327-074843_Chrome-1-115x250.jpg 115w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Screenshot_20200327-074843_Chrome-1-223x483.jpg 223w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Screenshot_20200327-074843_Chrome-1-194x420.jpg 194w" sizes="(max-width: 540px) 100vw, 540px" /> <img class="aligncenter size-full wp-image-359240" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/20200327_074230.jpg" alt="" width="1069" height="1353" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/20200327_074230.jpg 1069w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/20200327_074230-198x250.jpg 198w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/20200327_074230-768x972.jpg 768w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/20200327_074230-382x483.jpg 382w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/20200327_074230-696x881.jpg 696w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/20200327_074230-1068x1352.jpg 1068w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/20200327_074230-332x420.jpg 332w" sizes="(max-width: 1069px) 100vw, 1069px" /></p>
<p>May he rest in peace.</p>
<h3><a href="https://mpasho.co.ke/this-is-why-mike-sonkos-post-on-bill-gates-has-gone-viral/"><span style="color: #0000ff;">This is why Mike Sonko’s post on Bill Gates has gone viral</span></a></h3>
<p>Bereaved fans paid their tributes.</p>
<p>@<strong>talliaoyando</strong>: Rest Peacefully Inna Zion Rudeboy Shufflin #AppleGabriel ❤Yellow heartGreen heart.</p>
<p>@<strong>JahsolidrockM</strong>: Shocked by the news that #AppleGabriel passed away. 10 years ago we worked with him in Atlanta on the Teach Them Right album. An intense experience with this very special and gifted man. Thanks for all the great music and inspiration Apple, Rest in Peace!</p>
<p>@<strong>Mate_Tongola</strong>: There is no end to a good thing&#8230; Go well #AppleGabriel and thank you for the memories.</p>
<p>@<strong>maddznexusone</strong>: #AppleGabriel&#8221;What you don&#8217;t like for yourself don&#8217;t give it&#8221; Rest in Power..!</p>
<p>@<strong>DeeejaySlyde</strong>: Might Do an Israel Vibration appreciation mixtape Thinking face #AppleGabriel ❤Green heartYellow heart<br />
Student of Devt</p>
<p>@<strong>OkechE_O</strong>: RIP #AppleGabriel, you made Nairobi easy for me when I didn&#8217;t have a home. Pass on regards to the angels.</p>
<blockquote class="twitter-tweet" data-width="550">
<p lang="und" dir="ltr">RIP <a href="https://twitter.com/hashtag/AppleGabriel?src=hash&amp;ref_src=twsrc%5Etfw">#AppleGabriel</a> <a href="https://twitter.com/hashtag/israelvibration?src=hash&amp;ref_src=twsrc%5Etfw">#israelvibration</a><a href="https://t.co/cBpIWlZHrv">https://t.co/cBpIWlZHrv</a></p>
<p>&mdash; Dubman_Irie (@DubmanIrie) <a href="https://twitter.com/DubmanIrie/status/1243131473957466112?ref_src=twsrc%5Etfw">March 26, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="550">
<p lang="en" dir="ltr">Walk the streets of Glory..</p>
<p>Good bye <a href="https://twitter.com/hashtag/AppleGabriel?src=hash&amp;ref_src=twsrc%5Etfw">#AppleGabriel</a>. Rest in Perfect peace Rasta <a href="https://t.co/YbnJg1rhwb">pic.twitter.com/YbnJg1rhwb</a></p>
<p>&mdash; 𝐑𝐢𝐞𝐤 𝐌𝐚𝐜𝐡𝐚𝐫 (@RiekMachar3) <a href="https://twitter.com/RiekMachar3/status/1243399744254140419?ref_src=twsrc%5Etfw">March 27, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<div class="td-a-rec td-a-rec-id-content_bottom  "><div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
                      window._taboola = window._taboola || [];
                      _taboola.push({
                        mode: 'thumbnails-b',
                        container: 'taboola-below-article-thumbnails',
                        placement: 'Below Article Thumbnails',
                        target_type: 'mix'
                      });
                    </script></div> </div>
<footer>
<div class="td-post-source-tags">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://mpasho.co.ke/tag/apple-gabriel/">Apple Gabriel</a></li></ul>

<div class="mpcomments">DISCUSS THIS</div>
<div class="fb-comments" data-href="https://mpasho.co.ke/rest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on/" data-width="100%" data-numposts="10" data-order-by="social" data-colorscheme="light"></div>

</div>
<div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://mpasho.co.ke/size-8-sitting-room-photos/">Bonge la nyumba: Photos of Size 8&#8217;s posh sitting room where she is in quarantine</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://mpasho.co.ke/bro-if-she-says-hes-just-a-friend-zaris-son-raphael-shares-love-advice/">&#8216;Bro, if she says he&#8217;s just a friend&#8230;&#8217; Zari&#8217;s son Raphael shares love advice</a></div></div></div> <div class="author-box-wrap"><a href="https://mpasho.co.ke/author/grace-kerongo/"><img src="https://cdn.mpasho.co.ke/wp-content/uploads/2019/07/Screen-Shot-2019-07-13-at-5.17.44-PM-249x250.png" width="96" height="96" alt="Grace Kerongo" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://mpasho.co.ke/author/grace-kerongo/">Grace Kerongo</a></span></div><div class="td-author-description">I'm a nerd. I do nerdy stuff.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Grace Kerongo"></span><meta itemprop="datePublished" content="2020-03-27T08:00:53+00:00"><meta itemprop="dateModified" content="2020-03-27T08:00:53+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://mpasho.co.ke/rest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on/" /><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://media.mpasho.co.ke/wp-content/uploads/templateassets/logo_main_300x100px.png"></span><meta itemprop="name" content="Mpasho News"></span><meta itemprop="headline " content="Rest in peace legend! Reggae music great Apple Gabriel passes on"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/EUBkkhTXgAMnqcx.jpeg"><meta itemprop="width" content="600"><meta itemprop="height" content="754"></span> <div class="td-post-sharing td-post-sharing-bottom "><span class="td-post-share-title">SHARE</span>
<div class="td-default-sharing">
<a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fmpasho.co.ke%2Frest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
<a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Rest+in+peace+legend%21+Reggae+music+great+Apple+Gabriel+passes+on&url=https%3A%2F%2Fmpasho.co.ke%2Frest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on%2F&via=MpashoNews"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
<a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://mpasho.co.ke/rest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
<a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://mpasho.co.ke/rest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on/&amp;media=https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/EUBkkhTXgAMnqcx.jpeg&description=Reggae has been stopped, temporarily by the sudden death of Jamaican legend Apple Gabriel." onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
<a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Rest+in+peace+legend%21+Reggae+music+great+Apple+Gabriel+passes+on%20-%20https%3A%2F%2Fmpasho.co.ke%2Frest-in-peace-legend-reggae-music-great-apple-gabriel-passes-on%2F"><i class="td-icon-whatsapp"></i></a>
</div></div> </footer>
<div class="belowcontentinfo">
<div class="mpashotvsec">MPASHO TV</div>
<iframe width="640" height="360" src="https://www.youtube.com/embed/videoseries?list=PLCKgoGv7yz0ZXovAJxMYCRC_9S860aycL" frameborder="0" allowfullscreen></iframe>
</div>
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<div class="td-a-rec td-a-rec-id-sidebar  ">
<div id='div-gpt-ad-1574225080085-0' style='width: 300px; height: 600px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1574225080085-0'); });
  </script>
</div></div><div class="td_block_wrap td_block_18 td_block_widget td_uid_38_5e7db74bdebe1_rand td-pb-border-top" data-td-block-uid="td_uid_38_5e7db74bdebe1"><script>var block_td_uid_38_5e7db74bdebe1 = new tdBlock();
block_td_uid_38_5e7db74bdebe1.id = "td_uid_38_5e7db74bdebe1";
block_td_uid_38_5e7db74bdebe1.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"Trending on Mpasho","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_38_5e7db74bdebe1_rand","el_class":"","offset":"25","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_38_5e7db74bdebe1.td_column_number = "1";
block_td_uid_38_5e7db74bdebe1.block_type = "td_block_18";
block_td_uid_38_5e7db74bdebe1.post_count = "5";
block_td_uid_38_5e7db74bdebe1.found_posts = "35950";
block_td_uid_38_5e7db74bdebe1.header_color = "#";
block_td_uid_38_5e7db74bdebe1.ajax_pagination_infinite_stop = "";
block_td_uid_38_5e7db74bdebe1.max_num_pages = "7185";
tdBlocksArray.push(block_td_uid_38_5e7db74bdebe1);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span>Trending on Mpasho</span></h4></div><div id=td_uid_38_5e7db74bdebe1 class="td_block_inner td-column-1">
<div class="td_module_mx8 td_module_wrap td-animation-stack">
<div class="meta-info-container">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/wavinya-ndeti-pays-tribute-to-late-husband/" rel="bookmark" title="&#8216;We were late!&#8217; Wavinya Ndeti on finding out her late husband had colon cancer"><img width="512" height="384" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/ET51301XsAcweuE.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/ET51301XsAcweuE.jpg 512w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/ET51301XsAcweuE-333x250.jpg 333w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/ET51301XsAcweuE-80x60.jpg 80w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/ET51301XsAcweuE-265x198.jpg 265w" sizes="(max-width: 512px) 100vw, 512px" alt="" title="&#8216;We were late!&#8217; Wavinya Ndeti on finding out her late husband had colon cancer" /></a></div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/wavinya-ndeti-pays-tribute-to-late-husband/" rel="bookmark" title="&#8216;We were late!&#8217; Wavinya Ndeti on finding out her late husband had colon cancer">&#8216;We were late!&#8217; Wavinya Ndeti on finding out her late husband had colon cancer</a></h3> <span class="td-author-date">
<span class="td-post-author-name"><a href="https://mpasho.co.ke/author/peninah-njoki/">Peninah Njoki</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-26T12:30:25+00:00">March 26, 2020</time></span> </span>
</div>
</div>
</div>
<div class="td_module_mx2 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/drama-harmonizes-album-pulled/" rel="bookmark" title="Drama as Harmonize&#8217;s album is pulled down losing millions of views"><img width="80" height="60" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2019/10/harmonize-80x60.png" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2019/10/harmonize-80x60.png 80w, https://cdn.mpasho.co.ke/wp-content/uploads/2019/10/harmonize-265x198.png 265w" sizes="(max-width: 80px) 100vw, 80px" alt="" title="Drama as Harmonize&#8217;s album is pulled down losing millions of views" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/drama-harmonizes-album-pulled/" rel="bookmark" title="Drama as Harmonize&#8217;s album is pulled down losing millions of views">Drama as Harmonize&#8217;s album is pulled down losing millions of views</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-26T12:00:32+00:00">March 26, 2020</time></span> </div>
</div>
</div>
<div class="td_module_mx2 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/wacha-panganga-and-pay-dj-evolves-bill-kenyans-react-babu-owino-after-offering-50-paycut-for-covoranirus/" rel="bookmark" title="&#8216;Wacha pang&#8217;ang&#8217;a and pay DJ Evolve&#8217;s bill!&#8217; KOT reacts to Babu Owino for taking a 50% paycut"><img width="80" height="60" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Babu-Owino-mauled-80x60.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Babu-Owino-mauled-80x60.jpg 80w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Babu-Owino-mauled-265x198.jpg 265w" sizes="(max-width: 80px) 100vw, 80px" alt="Babu Owino" title="&#8216;Wacha pang&#8217;ang&#8217;a and pay DJ Evolve&#8217;s bill!&#8217; KOT reacts to Babu Owino for taking a 50% paycut" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/wacha-panganga-and-pay-dj-evolves-bill-kenyans-react-babu-owino-after-offering-50-paycut-for-covoranirus/" rel="bookmark" title="&#8216;Wacha pang&#8217;ang&#8217;a and pay DJ Evolve&#8217;s bill!&#8217; KOT reacts to Babu Owino for taking a 50% paycut">&#8216;Wacha pang&#8217;ang&#8217;a and pay DJ Evolve&#8217;s bill!&#8217; KOT reacts to Babu Owino for taking a 50% paycut</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-26T11:30:43+00:00">March 26, 2020</time></span> </div>
</div>
</div>
<div class="td_module_mx2 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/captain-kale-gives-marital-advise/" rel="bookmark" title="&#8216;Stop judging a woman&#8217;s attitude with her marital status,&#8217; Captain Kale advises"><img width="80" height="60" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2019/03/Captain-Kale-80x60.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2019/03/Captain-Kale-80x60.jpg 80w, https://cdn.mpasho.co.ke/wp-content/uploads/2019/03/Captain-Kale-265x198.jpg 265w" sizes="(max-width: 80px) 100vw, 80px" alt="Captain Kale" title="&#8216;Stop judging a woman&#8217;s attitude with her marital status,&#8217; Captain Kale advises" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/captain-kale-gives-marital-advise/" rel="bookmark" title="&#8216;Stop judging a woman&#8217;s attitude with her marital status,&#8217; Captain Kale advises">&#8216;Stop judging a woman&#8217;s attitude with her marital status,&#8217; Captain Kale advises</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-26T11:00:20+00:00">March 26, 2020</time></span> </div>
</div>
</div>
<div class="td_module_mx2 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/mwai-kibaki-junior-shares-long-lasting-relationship-advice/" rel="bookmark" title="Love guru! Mwai Kibaki Junior shares long-lasting relationship advice"><img width="80" height="60" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/mwai-kibaki-jnr--80x60.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/mwai-kibaki-jnr--80x60.jpg 80w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/mwai-kibaki-jnr--265x198.jpg 265w" sizes="(max-width: 80px) 100vw, 80px" alt="mwai kibaki jnr" title="Love guru! Mwai Kibaki Junior shares long-lasting relationship advice" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/mwai-kibaki-junior-shares-long-lasting-relationship-advice/" rel="bookmark" title="Love guru! Mwai Kibaki Junior shares long-lasting relationship advice">Love guru! Mwai Kibaki Junior shares long-lasting relationship advice</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-26T10:26:54+00:00">March 26, 2020</time></span> </div>
</div>
</div>
</div></div> <div class="td-a-rec td-a-rec-id-custom_ad_2  ">
<div id='div-gpt-ad-1560413099409-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1560413099409-0'); });
</script>
</div></div><aside class="widget widget_archive"><div class="block-title"><span>MPASHO ARCHIVES</span></div> <label class="screen-reader-text" for="archives-dropdown-2">MPASHO ARCHIVES</label>
<select id="archives-dropdown-2" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
<option value="">Select Month</option>
<option value='https://mpasho.co.ke/2020/03/'> March 2020 </option>
<option value='https://mpasho.co.ke/2020/02/'> February 2020 </option>
<option value='https://mpasho.co.ke/2020/01/'> January 2020 </option>
<option value='https://mpasho.co.ke/2019/12/'> December 2019 </option>
<option value='https://mpasho.co.ke/2019/11/'> November 2019 </option>
<option value='https://mpasho.co.ke/2019/10/'> October 2019 </option>
<option value='https://mpasho.co.ke/2019/09/'> September 2019 </option>
<option value='https://mpasho.co.ke/2019/08/'> August 2019 </option>
<option value='https://mpasho.co.ke/2019/07/'> July 2019 </option>
<option value='https://mpasho.co.ke/2019/06/'> June 2019 </option>
<option value='https://mpasho.co.ke/2019/05/'> May 2019 </option>
<option value='https://mpasho.co.ke/2019/04/'> April 2019 </option>
<option value='https://mpasho.co.ke/2019/03/'> March 2019 </option>
<option value='https://mpasho.co.ke/2019/02/'> February 2019 </option>
<option value='https://mpasho.co.ke/2019/01/'> January 2019 </option>
<option value='https://mpasho.co.ke/2018/12/'> December 2018 </option>
<option value='https://mpasho.co.ke/2018/11/'> November 2018 </option>
<option value='https://mpasho.co.ke/2018/10/'> October 2018 </option>
<option value='https://mpasho.co.ke/2018/09/'> September 2018 </option>
<option value='https://mpasho.co.ke/2018/08/'> August 2018 </option>
<option value='https://mpasho.co.ke/2018/07/'> July 2018 </option>
<option value='https://mpasho.co.ke/2018/06/'> June 2018 </option>
<option value='https://mpasho.co.ke/2018/05/'> May 2018 </option>
<option value='https://mpasho.co.ke/2018/04/'> April 2018 </option>
<option value='https://mpasho.co.ke/2018/03/'> March 2018 </option>
<option value='https://mpasho.co.ke/2018/02/'> February 2018 </option>
<option value='https://mpasho.co.ke/2018/01/'> January 2018 </option>
<option value='https://mpasho.co.ke/2017/12/'> December 2017 </option>
<option value='https://mpasho.co.ke/2017/11/'> November 2017 </option>
<option value='https://mpasho.co.ke/2017/10/'> October 2017 </option>
<option value='https://mpasho.co.ke/2017/09/'> September 2017 </option>
<option value='https://mpasho.co.ke/2017/08/'> August 2017 </option>
<option value='https://mpasho.co.ke/2017/07/'> July 2017 </option>
<option value='https://mpasho.co.ke/2017/06/'> June 2017 </option>
<option value='https://mpasho.co.ke/2017/05/'> May 2017 </option>
<option value='https://mpasho.co.ke/2017/04/'> April 2017 </option>
<option value='https://mpasho.co.ke/2017/03/'> March 2017 </option>
<option value='https://mpasho.co.ke/2017/02/'> February 2017 </option>
<option value='https://mpasho.co.ke/2017/01/'> January 2017 </option>
<option value='https://mpasho.co.ke/2016/12/'> December 2016 </option>
<option value='https://mpasho.co.ke/2016/11/'> November 2016 </option>
<option value='https://mpasho.co.ke/2016/10/'> October 2016 </option>
<option value='https://mpasho.co.ke/2016/09/'> September 2016 </option>
<option value='https://mpasho.co.ke/2016/08/'> August 2016 </option>
<option value='https://mpasho.co.ke/2016/07/'> July 2016 </option>
<option value='https://mpasho.co.ke/2016/06/'> June 2016 </option>
<option value='https://mpasho.co.ke/2016/05/'> May 2016 </option>
<option value='https://mpasho.co.ke/2016/04/'> April 2016 </option>
<option value='https://mpasho.co.ke/2016/03/'> March 2016 </option>
<option value='https://mpasho.co.ke/2016/02/'> February 2016 </option>
<option value='https://mpasho.co.ke/2016/01/'> January 2016 </option>
<option value='https://mpasho.co.ke/2015/12/'> December 2015 </option>
<option value='https://mpasho.co.ke/2015/11/'> November 2015 </option>
<option value='https://mpasho.co.ke/2015/10/'> October 2015 </option>
<option value='https://mpasho.co.ke/2015/09/'> September 2015 </option>
<option value='https://mpasho.co.ke/2015/08/'> August 2015 </option>
<option value='https://mpasho.co.ke/2015/07/'> July 2015 </option>
<option value='https://mpasho.co.ke/2015/06/'> June 2015 </option>
<option value='https://mpasho.co.ke/2015/05/'> May 2015 </option>
<option value='https://mpasho.co.ke/2015/04/'> April 2015 </option>
<option value='https://mpasho.co.ke/2015/03/'> March 2015 </option>
<option value='https://mpasho.co.ke/2015/02/'> February 2015 </option>
<option value='https://mpasho.co.ke/2015/01/'> January 2015 </option>
<option value='https://mpasho.co.ke/2014/12/'> December 2014 </option>
<option value='https://mpasho.co.ke/2014/11/'> November 2014 </option>
<option value='https://mpasho.co.ke/2014/10/'> October 2014 </option>
<option value='https://mpasho.co.ke/2014/09/'> September 2014 </option>
</select>
</aside><div class="td_block_wrap td_block_slide td_block_widget td_uid_41_5e7db752e22bc_rand td-pb-border-top" data-td-block-uid="td_uid_41_5e7db752e22bc"><script>var block_td_uid_41_5e7db752e22bc = new tdBlock();
block_td_uid_41_5e7db752e22bc.id = "td_uid_41_5e7db752e22bc";
block_td_uid_41_5e7db752e22bc.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"3524","category_ids":"1,2","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_41_5e7db752e22bc_rand","el_class":"","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_41_5e7db752e22bc.td_column_number = "1";
block_td_uid_41_5e7db752e22bc.block_type = "td_block_slide";
block_td_uid_41_5e7db752e22bc.post_count = "5";
block_td_uid_41_5e7db752e22bc.found_posts = "3680";
block_td_uid_41_5e7db752e22bc.header_color = "#";
block_td_uid_41_5e7db752e22bc.ajax_pagination_infinite_stop = "";
block_td_uid_41_5e7db752e22bc.max_num_pages = "736";
tdBlocksArray.push(block_td_uid_41_5e7db752e22bc);
</script><div class="td-block-title-wrap"></div><div id=td_uid_41_5e7db752e22bc class="td_block_inner"><div id="td_uid_42_5e7db752e30a2" class="td-theme-slider iosSlider-col-1 td_mod_wrap"><div class="td-slider "><div id="td_uid_42_5e7db752e30a2_item_0" class="td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://mpasho.co.ke/quarantine-fans-question-corazon-kwamboka-maureen-waititus-ex-frankie/" rel="bookmark" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie"><img width="324" height="218" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2016/06/Frankie-Trainer2.jpg" alt="" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie" /></a></div><div class="td-slide-meta"><span class="slide-meta-cat"><a href="https://mpasho.co.ke/category/entertainment/">Entertainment</a></span><h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/quarantine-fans-question-corazon-kwamboka-maureen-waititus-ex-frankie/" rel="bookmark" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie">&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie</a></h3><div class="td-module-meta-info"><span class="td-post-author-name"><a href="https://mpasho.co.ke/author/elizabeth-musyimi/">Queen Serem</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-27T11:15:21+00:00">March 27, 2020</time></span></div></div></div><div id="td_uid_42_5e7db752e30a2_item_1" class="td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://mpasho.co.ke/house-arrest-read-zari-hassans-letter-estate-management/" rel="bookmark" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management"><img width="324" height="400" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Zari-Hassan-666-324x400.jpg" alt="Zari Hassan" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management" /></a></div><div class="td-slide-meta"><span class="slide-meta-cat"><a href="https://mpasho.co.ke/category/entertainment/">Entertainment</a></span><h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/house-arrest-read-zari-hassans-letter-estate-management/" rel="bookmark" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management">&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management</a></h3><div class="td-module-meta-info"><span class="td-post-author-name"><a href="https://mpasho.co.ke/author/elizabeth-musyimi/">Queen Serem</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-27T11:10:50+00:00">March 27, 2020</time></span></div></div></div><div id="td_uid_42_5e7db752e30a2_item_2" class="td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://mpasho.co.ke/i-chipod-her-jowie-leaves-fans-in-stitches-after-scare/" rel="bookmark" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;"><img width="324" height="400" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/JOWIE-JOWI-88-324x400.jpg" alt="Jowie Joe" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;" /></a></div><div class="td-slide-meta"><span class="slide-meta-cat"><a href="https://mpasho.co.ke/category/entertainment/">Entertainment</a></span><h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/i-chipod-her-jowie-leaves-fans-in-stitches-after-scare/" rel="bookmark" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;">&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;</a></h3><div class="td-module-meta-info"><span class="td-post-author-name"><a href="https://mpasho.co.ke/author/elizabeth-musyimi/">Queen Serem</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-27T10:42:44+00:00">March 27, 2020</time></span></div></div></div><div id="td_uid_42_5e7db752e30a2_item_3" class="td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://mpasho.co.ke/atatoklezea-tu-j-blessings-ex-chantelle-search-soulmate/" rel="bookmark" title="Atatoklezea tu! J Blessing&#8217;s ex Chantelle in search of her soulmate"><img width="324" height="400" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/unnamed-file-324x400.jpg" alt="" title="Atatoklezea tu! J Blessing&#8217;s ex Chantelle in search of her soulmate" /></a></div><div class="td-slide-meta"><span class="slide-meta-cat"><a href="https://mpasho.co.ke/category/entertainment/">Entertainment</a></span><h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/atatoklezea-tu-j-blessings-ex-chantelle-search-soulmate/" rel="bookmark" title="Atatoklezea tu! J Blessing&#8217;s ex Chantelle in search of her soulmate">Atatoklezea tu! J Blessing&#8217;s ex Chantelle in search of her soulmate</a></h3><div class="td-module-meta-info"><span class="td-post-author-name"><a href="https://mpasho.co.ke/author/elizabeth-musyimi/">Queen Serem</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-27T10:00:15+00:00">March 27, 2020</time></span></div></div></div><div id="td_uid_42_5e7db752e30a2_item_4" class="td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://mpasho.co.ke/bro-if-she-says-hes-just-a-friend-zaris-son-raphael-shares-love-advice/" rel="bookmark" title="&#8216;Bro, if she says he&#8217;s just a friend&#8230;&#8217; Zari&#8217;s son Raphael shares love advice"><img width="324" height="400" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/raphael-324x400.jpg" alt="" title="&#8216;Bro, if she says he&#8217;s just a friend&#8230;&#8217; Zari&#8217;s son Raphael shares love advice" /></a></div><div class="td-slide-meta"><span class="slide-meta-cat"><a href="https://mpasho.co.ke/category/entertainment/">Entertainment</a></span><h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/bro-if-she-says-hes-just-a-friend-zaris-son-raphael-shares-love-advice/" rel="bookmark" title="&#8216;Bro, if she says he&#8217;s just a friend&#8230;&#8217; Zari&#8217;s son Raphael shares love advice">&#8216;Bro, if she says he&#8217;s just a friend&#8230;&#8217; Zari&#8217;s son Raphael shares love advice</a></h3><div class="td-module-meta-info"><span class="td-post-author-name"><a href="https://mpasho.co.ke/author/elizabeth-musyimi/">Queen Serem</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-27T08:30:15+00:00">March 27, 2020</time></span></div></div></div></div><i class="td-icon-left prevButton"></i><i class="td-icon-right nextButton"></i></div></div></div> <div class="td_block_wrap td_block_3 td_block_widget td_uid_43_5e7db752e4e5f_rand td-pb-border-top" data-td-block-uid="td_uid_43_5e7db752e4e5f"><script>var block_td_uid_43_5e7db752e4e5f = new tdBlock();
block_td_uid_43_5e7db752e4e5f.id = "td_uid_43_5e7db752e4e5f";
block_td_uid_43_5e7db752e4e5f.atts = '{"limit":"3","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"5","category_ids":"","custom_title":"MUSIC & RADIO","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_43_5e7db752e4e5f_rand","el_class":"","offset":"10","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_43_5e7db752e4e5f.td_column_number = "1";
block_td_uid_43_5e7db752e4e5f.block_type = "td_block_3";
block_td_uid_43_5e7db752e4e5f.post_count = "3";
block_td_uid_43_5e7db752e4e5f.found_posts = "6743";
block_td_uid_43_5e7db752e4e5f.header_color = "#";
block_td_uid_43_5e7db752e4e5f.ajax_pagination_infinite_stop = "";
block_td_uid_43_5e7db752e4e5f.max_num_pages = "2245";
tdBlocksArray.push(block_td_uid_43_5e7db752e4e5f);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span>MUSIC &amp; RADIO</span></h4></div><div id=td_uid_43_5e7db752e4e5f class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_1 td_module_wrap td-animation-stack">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/redemption-music-growing-violent-home/" rel="bookmark" title="&#8216;My step-dad almost killed me,&#8217; Gospel artiste Redemption Musiq opens up"><img width="324" height="160" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/87480736_3524889550919873_7516869126873272580_n-324x160.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/87480736_3524889550919873_7516869126873272580_n-324x160.jpg 324w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/87480736_3524889550919873_7516869126873272580_n-533x261.jpg 533w" sizes="(max-width: 324px) 100vw, 324px" alt="" title="&#8216;My step-dad almost killed me,&#8217; Gospel artiste Redemption Musiq opens up" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/redemption-music-growing-violent-home/" rel="bookmark" title="&#8216;My step-dad almost killed me,&#8217; Gospel artiste Redemption Musiq opens up">&#8216;My step-dad almost killed me,&#8217; Gospel artiste Redemption Musiq opens up</a></h3>
<div class="td-module-meta-info">
<span class="td-post-author-name"><a href="https://mpasho.co.ke/author/peninah-njoki/">Peninah Njoki</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-25T13:00:28+00:00">March 25, 2020</time></span> </div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_1 td_module_wrap td-animation-stack">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/shoot-your-shot-harmonize-ex-girlfriend-wolper-is-auditioning-for-a-man-to-give-birth-with/" rel="bookmark" title="Shoot your shot! Harmonize&#8217; ex-girlfriend Wolper is auditioning for a man to give birth with"><img width="324" height="160" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/wolper-1-324x160.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/wolper-1-324x160.jpg 324w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/wolper-1-533x261.jpg 533w" sizes="(max-width: 324px) 100vw, 324px" alt="" title="Shoot your shot! Harmonize&#8217; ex-girlfriend Wolper is auditioning for a man to give birth with" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/shoot-your-shot-harmonize-ex-girlfriend-wolper-is-auditioning-for-a-man-to-give-birth-with/" rel="bookmark" title="Shoot your shot! Harmonize&#8217; ex-girlfriend Wolper is auditioning for a man to give birth with">Shoot your shot! Harmonize&#8217; ex-girlfriend Wolper is auditioning for a man...</a></h3>
<div class="td-module-meta-info">
<span class="td-post-author-name"><a href="https://mpasho.co.ke/author/elizabeth-musyimi/">Queen Serem</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-24T14:30:58+00:00">March 24, 2020</time></span> </div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_1 td_module_wrap td-animation-stack">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/ndio-huyu-meet-the-boyfriend-to-diamond-platnumz-jeje-video-vixen/" rel="bookmark" title="Ndio huyu! Meet the boyfriend to Diamond Platnumz&#8217; Jeje video vixen"><img width="324" height="160" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/iamond-Platnunz-and-Malaika-324x160.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/iamond-Platnunz-and-Malaika-324x160.jpg 324w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/iamond-Platnunz-and-Malaika-533x261.jpg 533w" sizes="(max-width: 324px) 100vw, 324px" alt="Diamond Platnunz and Malaika" title="Ndio huyu! Meet the boyfriend to Diamond Platnumz&#8217; Jeje video vixen" /></a></div> <a href="https://mpasho.co.ke/category/entertainment/" class="td-post-category">Entertainment</a> </div>
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/ndio-huyu-meet-the-boyfriend-to-diamond-platnumz-jeje-video-vixen/" rel="bookmark" title="Ndio huyu! Meet the boyfriend to Diamond Platnumz&#8217; Jeje video vixen">Ndio huyu! Meet the boyfriend to Diamond Platnumz&#8217; Jeje video vixen</a></h3>
<div class="td-module-meta-info">
<span class="td-post-author-name"><a href="https://mpasho.co.ke/author/elizabeth-musyimi/">Queen Serem</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-24T13:00:57+00:00">March 24, 2020</time></span> </div>
</div>

</div> </div></div> <div class="td-a-rec td-a-rec-id-custom_ad_3  ">
<div id='div-gpt-ad-1560413140164-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1560413140164-0'); });
</script>
</div></div> </div>
</div>
</div> 
</article> 
</div> 
</div> 


<div class="td-footer-wrapper td-footer-template-3">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-footer_top ">
<script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-6073518695523995" data-ad-slot=""></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-6073518695523995" data-ad-slot=""></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-6073518695523995" data-ad-slot=""></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6073518695523995" data-ad-slot=""></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span4">
<div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://mpasho.co.ke/"><img class="td-retina-data" src="https://media.mpasho.co.ke/wp-content/uploads/templateassets/logo_main_300x100px.png" data-retina="https://media.mpasho.co.ke/wp-content/uploads/templateassets/logo_main_300x100px.png" alt="Mpasho News" title="Mpasho Entertainment News" /></a></div><div class="footer-text-wrap">Mpasho is your go-to entertainment and lifestyle news website. We provide you with the latest breaking news, gossip and videos straight from the industry.<div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#1871767e77587568796b7077367b7736737d"><span class="__cf_email__" data-cfemail="e28b8c848da28f9283918a8dcc818dcc8987">[email&#160;protected]</span></a></div></div><div class="footer-social-wrap td-social-style-2"></div></div> </div>
<div class="td-pb-span4">
<aside class="widget widget_text"> <div class="textwidget"><center>
<div class="tips">
<p><a href='https://mpasho.co.ke/mpasho/hot-tip/' target='_blank'><img src='https://cdn.mpasho.co.ke/wp-content/uploads/2014/09/tips.png' /></a></p>
</div>
</center>
</div>
</aside> </div>
<div class="td-pb-span4">
<aside class="widget widget_text"> <div class="textwidget"><center>
<div class="paparazzi">
<p><a href='https://bit.ly/mpashorazzipopup' target='_blank'><img src='https://media.mpasho.co.ke/wp-content/uploads/2014/09/paparazziv1.2.png' /></a></p>
</div>
</center>
</div>
</aside> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span7 td-sub-footer-menu">
<div class="menu-td_demo_footer-container"><ul id="menu-td_demo_footer" class="td-subfooter-menu"><li id="menu-item-3196" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-3196"><a href="#">Content Partners</a>
<ul class="sub-menu">
<li id="menu-item-46119" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-46119"><a href="https://bit.ly/TheStarke">The Star</a></li>
<li id="menu-item-4133" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-4133"><a href="https://bit.ly/KenyaMOJAMpasho">KenyaMOJA</a></li>
<li id="menu-item-3194" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3194"><a title="Nyumbani Tv" href="https://bit.ly/NyumbaniTVMpasho">Nyumbani Tv</a></li>
<li id="menu-item-8061" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-8061"><a href="https://bit.ly/AfrollyNewsKenyaMpasho">Afrolly News</a></li>
<li id="menu-item-10825" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-10825"><a href="https://bit.ly/trendingnewsroom">Trending</a></li>
</ul>
</li>
<li id="menu-item-10" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-10"><a href="https://mpasho.co.ke/advertise/">Advertising</a></li>
<li id="menu-item-11" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-11"><a href="https://mpasho.co.ke/hot-tip/">Contact us</a></li>
<li id="menu-item-61021" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-61021"><a href="https://mpasho.co.ke/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
<div class="td-pb-span5 td-sub-footer-copy">
&copy; Copyright 2017 - Mpasho News </div>
</div>
</div>
</div>
</div>
<div class="td-more-articles-box">
<i class="td-icon-close td-close-more-articles-box"></i>
<span class="td-more-articles-box-title">MORE STORIES</span>
<div class="td-content-more-articles-box">
<div class="td_module_7 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/quarantine-fans-question-corazon-kwamboka-maureen-waititus-ex-frankie/" rel="bookmark" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie"><img width="100" height="67" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2016/06/Frankie-Trainer2.jpg" alt="" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/quarantine-fans-question-corazon-kwamboka-maureen-waititus-ex-frankie/" rel="bookmark" title="&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie">&#8216;Quarantine?&#8217; Fans question Corazon Kwamboka and Maureen Waititu&#8217;s ex Frankie</a></h3>
<div class="td-module-meta-info">
 <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-27T11:15:21+00:00">March 27, 2020</time></span> </div>
</div>
</div>
<div class="td_module_7 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/house-arrest-read-zari-hassans-letter-estate-management/" rel="bookmark" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management"><img width="100" height="70" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Zari-Hassan-666-100x70.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Zari-Hassan-666-100x70.jpg 100w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/Zari-Hassan-666-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Zari Hassan" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/house-arrest-read-zari-hassans-letter-estate-management/" rel="bookmark" title="&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate management">&#8216;We are under house arrest,&#8217; Read Zari Hassan&#8217;s letter from estate...</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-27T11:10:50+00:00">March 27, 2020</time></span> </div>
</div>
</div>
<div class="td_module_7 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/rough-rude-kate-actress-reveals-reasons-snob-fans/" rel="bookmark" title="Some are rough and rude! Kate actress reveals the reasons for being a snob to her fans"><img width="100" height="70" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/catt-100x70.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/catt-100x70.jpg 100w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/catt-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Some are rough and rude! Kate actress reveals the reasons for being a snob to her fans" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/rough-rude-kate-actress-reveals-reasons-snob-fans/" rel="bookmark" title="Some are rough and rude! Kate actress reveals the reasons for being a snob to her fans">Some are rough and rude! Kate actress reveals the reasons for...</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-27T11:00:03+00:00">March 27, 2020</time></span> </div>
</div>
</div>
<div class="td_module_7 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://mpasho.co.ke/i-chipod-her-jowie-leaves-fans-in-stitches-after-scare/" rel="bookmark" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;"><img width="100" height="70" class="entry-thumb" src="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/JOWIE-JOWI-88-100x70.jpg" srcset="https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/JOWIE-JOWI-88-100x70.jpg 100w, https://cdn.mpasho.co.ke/wp-content/uploads/2020/03/JOWIE-JOWI-88-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Jowie Joe" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://mpasho.co.ke/i-chipod-her-jowie-leaves-fans-in-stitches-after-scare/" rel="bookmark" title="&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;">&#8216;I chipod her,&#8217; Jowie leaves fans in stitches after &#8216;scare&#8217;</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-27T10:42:44+00:00">March 27, 2020</time></span> </div>
</div>
</div>
</div>
</div>


<style type="text/css" media="screen">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</style>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript' src='https://mpasho.co.ke/wp-content/themes/Newspaper/js/tagdiv_theme.js'></script>
<script type='text/javascript' src='https://mpasho.co.ke/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://mpasho.co.ke/wp-includes/js/wp-embed.min.js'></script>

<script>
    

jQuery(document).ready(function() {
    jQuery("#td_uid_42_5e7db752e30a2").iosSlider({
        snapToChildren: true,
        desktopClickDrag: true,
        keyboardControls: false,
        responsiveSlideContainer: true,
        responsiveSlides: true,
        

        infiniteSlider: true,
        navPrevSelector: jQuery("#td_uid_42_5e7db752e30a2 .prevButton"),
        navNextSelector: jQuery("#td_uid_42_5e7db752e30a2 .nextButton")
        ,
                //onSliderLoaded : td_resize_normal_slide,
                //onSliderResize : td_resize_normal_slide_and_update
    });
});
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://mpasho.co.ke/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://mpasho.co.ke/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>





<script type='text/javascript'>
    var _sf_async_config={};
    /** CONFIGURATION START **/
    /**_sf_async_config.uid = 64340; **/
    /**_sf_async_config.domain = 'mpasho.co.ke'; **/
    /**_sf_async_config.useCanonical = true; **/
    _sf_async_config.ytApikey = 'AIzaSyAn-9nlRN5TAL7_oNt-B-ALH4PQq2NhpGc';
    _sf_async_config.sections = "latest";
    _sf_async_config.authors = "Grace Kerongo";   
    /** CONFIGURATION END**/
    (function(){
      function loadChartbeat() {
        window._sf_endpt=(new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
         loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })();
</script>


<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>



<script type="text/javascript">
  var _paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setDocumentTitle", document.domain + "/" + document.title]);
  _paq.push(["setCookieDomain", "*.mpasho.co.ke"]);
  _paq.push(["setDomains", ["*.mpasho.co.ke"]]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//matomo.songamusic.com/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//matomo.songamusic.com/matomo.php?idsite=1&amp;rec=1" style="border:0;" alt="" /></p></noscript>


</body>
</html>
